Dismiss Notice
JOIN IGOTASLINGSHOT.COM TODAY!

100% free registration for all Polaris Slingshot enthusiasts. Businesses welcome to promote for (FREE) too.

My Slingshot not running great right now.

QuickSilverSS Jun 23, 2017

  1. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
    Hey all, My Slingshot not running great right now. Take a look at these pics of the spark plugs. 3 Black Spark Plugs and 1 White Spark Plug. I just took them out today to look at them.

    I have labeled them 1-4 and you will notice the 3nd one is "White" and the other 1, 2 and 4 are very "black".

    What do you think is wrong?
     

    Attached Files:

    Last edited: Jun 29, 2017
    IGOTASLINGSHOT likes this.
  2. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    130
    70
    28
    Yikes!

    How many miles on the plugs? Any mods?
     
  3. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
    Miles about 500 on this built motor. It has Supercharger and lots of other goodies. I need to upload somewhere on here my full build list. I am also getting smoke out of the exhaust, when I rev up the throttle I get lots more white/gray smoke. You certainly can smell the exhaust. Makes it not fun to ride.
     
    IGOTASLINGSHOT likes this.
  4. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    130
    70
    28
    Who tuned it?
     
  5. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
    Dave at DDM works.
     
  6. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    130
    70
    28
    The tune sounds off. Did you call him?
     
  7. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
  8. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    130
    70
    28
    What did he say?
     
  9. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
    So far we tried many many tune changes and it got worse and worse. That's when I pulled the spark plugs and see above. I am thinking its not tune related as that is not fixing it. Also loosing coolant, Was down 2 quarts of oil and was stalling at highway speeds and also would not stay idle at intersections. Getting white gray smoke out of exhaust and overall just bleh with the power it should have.
     
  10. David Michel

    David Michel New Member

    1
    1
    3
    QuicksilverSS has a very custom setup right now, larger custom supercharger, custom camshafts, Haltech ECM, water/meth injection, etc. which is pretty far from our standard setup. He is the first person to ever run this combination and is breaking new ground for the Slingshot community. We have been working with him long distance to try to see what is going on, sending tune updates but we have not been able to figure out the problem remotely. I am driving from South Carolina this weekend to see him in Houston to evaluate his Slingshot in person though and I am sure he will post up what we find after I have a look at it.

    Dave
     
    IGOTASLINGSHOT likes this.
  11. IGOTASLINGSHOT

    IGOTASLINGSHOT ADMIN Staff Member

    130
    70
    28
    Awesome! Please keep us informed.
     
  12. QuickSilverSS

    QuickSilverSS Supercharged

    11
    14
    3
    Yep Saturday morning!! Looking forward to it for sure. It is interesting about the unique aspect. I more or less was just curious about the spark plugs I pulled out to look at on my own what they mean looking like this.

    So from what I gathered online (multiple replies) with suggestions from folks is some cylinder(s) running Rich some cylinder(s) running Lean, Problem with injectors, maybe not best spark plugs. What would cause the soot and water to come out of the exhaust in relation to the way the spark plugs look?
     
    IGOTASLINGSHOT likes this.
  13. SlingRider

    SlingRider Member

    99
    85
    18
    Any update on this?

    Mine is having major issues also. :(
     
    IGOTASLINGSHOT likes this.